Performance degradation of SFTP in US and EU regions
Incident Report for Couchdrop Status
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 08:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2023 - 21:00 UTC
Investigating
We have had reports of poor performance and timeouts of uploads and downloads via SFTP in the US and AMS regions for Couchdrop over the last few days. The team has already remediated the root cause and is monitoring closely.

If you are still experiencing performance issues or timeouts, please contact support@couchdrop.io ASAP citing this reported issue.
Posted Mar 19, 2023 - 04:46 UTC
This incident affected: Couchdrop (SFTP, FTP/FTPS).